[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4A4D6439.8030302@cn.fujitsu.com>
Date: Fri, 03 Jul 2009 09:51:53 +0800
From: Li Zefan <lizf@...fujitsu.com>
To: Paul Menage <menage@...gle.com>
CC: KAMEZAWA Hiroyuki <kamezawa.hiroyu@...fujitsu.com>,
balbir@...ux.vnet.ibm.com, linux-kernel@...r.kernel.org,
akpm@...ux-foundation.org, containers@...ts.linux-foundation.org
Subject: Re: [PATCH 1/9] [RFC] Support named cgroups hierarchies
>>> /*
>>> * A cgroupfs_root represents the root of a cgroup hierarchy,
>>> * and may be associated with a superblock to form an active
>>> @@ -93,6 +95,9 @@ struct cgroupfs_root {
>>>
>>> /* The path to use for release notifications. */
>>> char release_agent_path[PATH_MAX];
>>> +
>>> + /* The name for this hierarchy - may be empty */
>>> + char name[MAX_CGROUP_ROOT_NAMELEN];
>>> };
>>>
>> If you don't want to make cgroupfs_root bigger,
>>
>> cgroupfs_root {
>> ......
>> /* this must be the bottom of struct */
>> char name[0];
>> }
>>
>> Is a choice.
>
> I'd rather avoid something like that since I think it's less readable
> - I'd probably just make the name into a pointer in that case.
>
Whichever choice we make, the length should be limited I think.
>> BTW, reading a patch, any kind of charactors are allowed ?
>
> Yes, other than \000 of course. I guess maybe I should use
> seq_escape() to print the name to avoid confusion in the event that
> people put whitespace in there, or else just ban whitespace (or maybe
> all non-alphanumeric chars).
>
I don't think we need to care about this.
mount -t cgroup -o debug xxx /mnt
"xxx" can be any chars.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists