[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20090706114558.GA19798@dhcp231-156.rdu.redhat.com>
Date: Mon, 6 Jul 2009 07:45:58 -0400
From: Josef Bacik <josef@...hat.com>
To: Amerigo Wang <amwang@...hat.com>
Cc: linux-kernel@...r.kernel.org, Jeff Mahoney <jeffm@...e.com>,
Yan Zheng <zheng.yan@...cle.com>,
Josef Bacik <jbacik@...hat.com>, Arjan <arjan@...radead.org>,
Chris Mason <chris.mason@...cle.com>, tao.ma@...cle.com,
akpm@...ux-foundation.org, linux-btrfs@...r.kernel.org,
Sven Wegener <sven.wegener@...aler.net>
Subject: Re: [Patch v3] btrfs: use file_remove_suid() after i_mutex is held
On Mon, Jul 06, 2009 at 05:15:33AM -0400, Amerigo Wang wrote:
>
> V2 -> V3:
> set 'err' to -ENOMEM when kmalloc() fails. Thanks to Tao.
>
> V1 -> V2:
> Move kmalloc() before mutex_lock(), suggested by Arjan.
>
> file_remove_suid() should be called with i_mutex held,
> file_update_time() too. So move them after mutex_lock().
>
> Plus, check the return value of kmalloc().
>
> Signed-off-by: WANG Cong <amwang@...hat.com>
> Cc: Arjan <arjan@...radead.org>
> Cc: Chris Mason <chris.mason@...cle.com>
> Cc: Yan Zheng <zheng.yan@...cle.com>
> Cc: Sven Wegener <sven.wegener@...aler.net>
> Cc: Josef Bacik <jbacik@...hat.com>
> Cc: Jeff Mahoney <jeffm@...e.com>
> Cc: Tao Ma <tao.ma@...cle.com>
>
> ---
> diff --git a/fs/btrfs/file.c b/fs/btrfs/file.c
> index 7c3cd24..e7b0d81 100644
> --- a/fs/btrfs/file.c
> +++ b/fs/btrfs/file.c
> @@ -944,14 +944,19 @@ static ssize_t btrfs_file_write(struct file *file, const char __user *buf,
> if (count == 0)
> goto out_nolock;
>
> + pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
> + if (!pages) {
> + err = -ENOMEM;
> + goto out_nolock;
> + }
> +
> + mutex_lock(&inode->i_mutex);
> +
> err = file_remove_suid(file);
> if (err)
> - goto out_nolock;
> + goto out;
> file_update_time(file);
>
> - pages = kmalloc(nrptrs * sizeof(struct page *), GFP_KERNEL);
> -
> - mutex_lock(&inode->i_mutex);
> BTRFS_I(inode)->sequence++;
> first_index = pos >> PAGE_CACHE_SHIFT;
> last_index = (pos + count) >> PAGE_CACHE_SHIFT;
Acked-by: Josef Bacik <jbacik@...hat.com>
Thanks,
Josef
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists