[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090721215536.GA9502@infradead.org>
Date: Tue, 21 Jul 2009 17:55:36 -0400
From: Christoph Hellwig <hch@...radead.org>
To: Alan Jenkins <alan-jenkins@...fmail.co.uk>
Cc: "Rafael J. Wysocki" <rjw@...k.pl>,
Heiko Carstens <heiko.carstens@...ibm.com>,
linux-kernel@...r.kernel.org,
Hans-Joachim Picht <hans@...ux.vnet.ibm.com>,
pm list <linux-pm@...ts.linux-foundation.org>,
Arnd Schneider <arnd@...ibm.com>, linux-fsdevel@...r.kernel.org
Subject: Re: PM/hibernate swapfile regression
On Tue, Jul 21, 2009 at 11:50:29AM +0100, Alan Jenkins wrote:
> +struct block_device *bdcopy(struct block_device *bdev)
> +{
> + atomic_inc(&bdev->bd_inode->i_count);
> + return bdev;
> +}
> +
> +EXPORT_SYMBOL(bdcopy);
The function name doesn't make any sense. You don't copy anything
here, but you grab a reference to it. A better name would be bdgrab,
mirroing the names of functions like igrab. A kerneldoc comment
documenting it would also be very helpful.
Why do you export it? The swapfile code is not actually modular.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists