lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20090817080023.GB2967@localdomain.by>
Date:	Mon, 17 Aug 2009 11:00:23 +0300
From:	Sergey Senozhatsky <sergey.senozhatsky@...il.com>
To:	Jiri Slaby <jirislaby@...il.com>
Cc:	akpm@...ux-foundation.org, andi@...stfloor.org,
	rpjday@...shcourse.ca, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/1] VIDEO: console, use DIV_ROUND_UP

On (08/17/09 09:48), Jiri Slaby wrote:
> On 08/17/2009 09:31 AM, Sergey Senozhatsky wrote:
> > On (08/17/09 09:15), Jiri Slaby wrote:
> >> Not at all. I was writing about about (X + 7) / 8 [or >> 3] which is
> >> DIV_ROUND_UP(X, 8).
> >>
> > As far as I can understand: 
> > DIV_ROUND_UP(61, 8):
> > (111101 + 111) >> 3 -> 1000 == 8
> > 
> > (int)(61/8) == 7
> 
> Yeah, that's why there is the ROUND_UP keyword in the macro.
> 
> I mean this:
> --
> Use DIV_ROUND_UP explicitly instead of manual shifts and adds. It makes
> the code more readable and consistent (sometimes there were shifts,
> sometimes divs).
> 
> There is no change on the assembly level (compilers should do the right
> job).
> 
> Signed-off-by: Jiri Slaby <jirislaby@...il.com>
> ---
>  drivers/video/console/bitblit.c |    8 ++++----
>  1 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/video/console/bitblit.c b/drivers/video/console/bitblit.c
> index 69864b1..6b7c8fb 100644
> --- a/drivers/video/console/bitblit.c
> +++ b/drivers/video/console/bitblit.c
> @@ -25,7 +25,7 @@ static inline void update_attr(u8 *dst, u8 *src, int attribute,
>  			       struct vc_data *vc)
>  {
>  	int i, offset = (vc->vc_font.height < 10) ? 1 : 2;
> -	int width = (vc->vc_font.width + 7) >> 3;
> +	int width = DIV_ROUND_UP(vc->vc_font.width, 8);

So... In general, ((vc->vc_font.width + 7) >> 3) ==  DIV_ROUND_UP(vc->vc_font.width, 8) - 1;
That means:
unsigned int cellsize = vc->vc_font.height * width;  now is  unsigned int cellsize = vc->vc_font.height * (width + 1);

Are you sure we really can use DIV_ROUND_UP?

	Sergey


Download attachment "signature.asc" of type "application/pgp-signature" (316 bytes)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ