[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1254845207-7608-1-git-send-email-haavard.skinnemoen@atmel.com>
Date: Tue, 6 Oct 2009 18:06:47 +0200
From: Haavard Skinnemoen <haavard.skinnemoen@...el.com>
To: Nicolas Ferre <nicolas.ferre@...el.com>
Cc: Andrew Victor <avictor.za@...il.com>, linux-kernel@...r.kernel.org,
akpm@...ux-foundation.org,
Haavard Skinnemoen <haavard.skinnemoen@...el.com>
Subject: [PATCH] atmel_serial: Fix bad BUILD_BUG_ON() usage
is_power_of_2() appears not to be constant enough for BUILD_BUG_ON()
after the latest rework, so replace it with an open-coded test.
Signed-off-by: Haavard Skinnemoen <haavard.skinnemoen@...el.com>
---
drivers/serial/atmel_serial.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/serial/atmel_serial.c b/drivers/serial/atmel_serial.c
index 3551c5c..9d948bc 100644
--- a/drivers/serial/atmel_serial.c
+++ b/drivers/serial/atmel_serial.c
@@ -1531,7 +1531,7 @@ static int __devinit atmel_serial_probe(struct platform_device *pdev)
void *data;
int ret;
- BUILD_BUG_ON(!is_power_of_2(ATMEL_SERIAL_RINGSIZE));
+ BUILD_BUG_ON(ATMEL_SERIAL_RINGSIZE & (ATMEL_SERIAL_RINGSIZE - 1));
port = &atmel_ports[pdev->id];
port->backup_imr = 0;
--
1.6.0.4
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists