[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.DEB.1.10.0910141008440.28461@gentwo.org>
Date: Wed, 14 Oct 2009 10:14:25 -0400 (EDT)
From: Christoph Lameter <cl@...ux-foundation.org>
To: Tejun Heo <tj@...nel.org>
cc: linux-kernel@...r.kernel.org,
Pekka Enberg <penberg@...helsinki.fi>,
Mel Gorman <mel@....ul.ie>,
Mathieu Desnoyers <mathieu.desnoyers@...ymtl.ca>
Subject: Re: [this_cpu_xx V6 3/7] Use this_cpu operations in slub
On Wed, 14 Oct 2009, Tejun Heo wrote:
> > __this_cpu_ptr could be converted to this_cpu_ptr but I think the __ are
> > useful there too to show that we are in a preempt section.
>
> That doesn't make much sense. __ for this_cpu_ptr() means "bypass
> sanity check, we're knowingly violating the required conditions" not
> "we know sanity checks will pass here".
Are you defining what __ means for this_cpu_ptr?
> > The calls to raw_smp_processor_id and smp_processor_id() are only useful
> > in the fallback case. There is no need for those if the arch has a way to
> > provide the current percpu offset. So we in effect have two meanings of __
> > right now.
> >
> > 1. We do not care about the preempt state (thus we call
> > raw_smp_processor_id so that the preempt state does not trigger)
> >
> > 2. We do not need to disable preempt before the operation.
> >
> > __this_cpu_ptr only implies 1. __this_cpu_add uses 1 and 2.
>
> Yeah, we need to clean it up. The naming is too confusing.
Its consistent if __ means both 1 and 2. If we want to distinguish it then
we may want to create raw_this_cpu_xx which means that we do not call
smp_processor_id() on fallback but raw_smp_processor_id(). Does not
matter if the arch provides a per cpu offset.
This would mean duplicating all the macros. The use of raw_this_cpu_xx
should be rare so maybe the best approach is to say that __ means only
that the macro does not need to disable preempt but it still checks for
preemption being off. Then audit the __this_cpu_xx uses and see if there
are any that require a raw_ variant.
The vm event counters require both no check and no preempt since they can
be implemented in a racy way.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists