[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20091016043618.GB11582@core.coreip.homeip.net>
Date: Thu, 15 Oct 2009 21:36:18 -0700
From: Dmitry Torokhov <dmitry.torokhov@...il.com>
To: Alex Chiang <achiang@...com>
Cc: lenb@...nel.org, shaohua.li@...el.com,
linux-kernel@...r.kernel.org, linux-acpi@...r.kernel.org
Subject: Re: [PATCH v2 1/6] ACPI: dock: clean up error handling paths in
dock_add()
Hi Alex,
On Wed, Oct 14, 2009 at 04:46:16PM -0600, Alex Chiang wrote:
> Remove some copy/paste code in our error handling paths, which makes
> the function smaller and slightly easier to read.
Changing individual attributes into attribute_group would greatly
simplify the code.
>
> Signed-off-by: Alex Chiang <achiang@...com>
> ---
>
> drivers/acpi/dock.c | 75 +++++++++++++++++++--------------------------------
> 1 files changed, 28 insertions(+), 47 deletions(-)
>
> diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
> index 7338b6a..642c7dd 100644
> --- a/drivers/acpi/dock.c
> +++ b/drivers/acpi/dock.c
> @@ -968,11 +968,9 @@ static int dock_add(acpi_handle handle)
> platform_device_register_simple(dock_device_name,
> dock_station_count, NULL, 0);
> dock_device = dock_station->dock_device;
> - if (IS_ERR(dock_device)) {
> - kfree(dock_station);
> - dock_station = NULL;
> - return PTR_ERR(dock_device);
> - }
> + ret = IS_ERR(dock_device) ? PTR_ERR(dock_device) : 0;
> + if (ret)
> + goto out;
I think
if (IS_ERR(dock_device)) {
ret = PTR_ERR(dock_device);
goto out;
}
is more commonly used form.
Thanks.
--
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists