[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20091017160338.GA10344@nowhere>
Date: Sat, 17 Oct 2009 18:03:41 +0200
From: Frederic Weisbecker <fweisbec@...il.com>
To: Ingo Molnar <mingo@...e.hu>
Cc: LKML <linux-kernel@...r.kernel.org>,
Peter Zijlstra <peterz@...radead.org>,
Arnaldo Carvalho de Melo <acme@...hat.com>,
Mike Galbraith <efault@....de>,
Paul Mackerras <paulus@...ba.org>,
Steven Rostedt <rostedt@...dmis.org>
Subject: Re: [PATCH 3/2] perf tools: Use DECLARE_BITMAP instead of an
open-coded array
On Sat, Oct 17, 2009 at 05:57:18PM +0200, Frederic Weisbecker wrote:
> Use DECLARE_BITMAP instead of an open coded array for our bitmap
> of featured sections.
>
> This makes the array an unsigned long instead of a u64 but since
> we use a 256 bits bitmap, the array size shouldn't vary between
> different boxes.
That said I would really feel more comfortable if someone can
confirm that.
> @@ -143,12 +141,12 @@ struct perf_file_header {
> struct perf_file_section attrs;
> struct perf_file_section data;
> struct perf_file_section event_types;
> - feat_mask_t adds_features;
> + DECLARE_BITMAP(adds_features, HEADER_FEAT_BITS);
I think having adds_features as an unsigned long won't
hurt because we have HEAD_FEAT_BITS % 64 == 0
It would certainly hurt if we had, say, HEAD_FEAT_BITS = 257
But may be I forget a corner case. I hope someone can double
check that. Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists