[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20091019194020.GC4880@nowhere>
Date: Mon, 19 Oct 2009 21:40:23 +0200
From: Frederic Weisbecker <fweisbec@...il.com>
To: Ingo Molnar <mingo@...e.hu>
Cc: LKML <linux-kernel@...r.kernel.org>,
Peter Zijlstra <peterz@...radead.org>,
Arnaldo Carvalho de Melo <acme@...hat.com>,
Mike Galbraith <efault@....de>,
Paul Mackerras <paulus@...ba.org>,
Steven Rostedt <rostedt@...dmis.org>
Subject: Re: [PATCH 3/2] perf tools: Use DECLARE_BITMAP instead of an
open-coded array
On Mon, Oct 19, 2009 at 09:30:39AM +0200, Ingo Molnar wrote:
>
> * Frederic Weisbecker <fweisbec@...il.com> wrote:
>
> > On Sat, Oct 17, 2009 at 05:57:18PM +0200, Frederic Weisbecker wrote:
> > > Use DECLARE_BITMAP instead of an open coded array for our bitmap
> > > of featured sections.
> > >
> > > This makes the array an unsigned long instead of a u64 but since we
> > > use a 256 bits bitmap, the array size shouldn't vary between
> > > different boxes.
> >
> > That said I would really feel more comfortable if someone can confirm
> > that.
>
> Should be size-invariant for the bitmap size of 256 bits due to:
>
> #define DECLARE_BITMAP(name,bits) \
> unsigned long name[BITS_TO_LONGS(bits)]
>
> but it's not little-endian/big-endian invariant.
>
> We should at minimum save the CPU architecture (and endianness
> parameters) the data got generated on, and reject
> endianness-incompatible uses - so that if someone wants to add
> cross-endian support it can be implemented cleanly.
>
> Ingo
Oh right, I'll add an endianness field then.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists