lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 10 Nov 2009 10:34:54 +0000
From:	"Phil Reynolds" <phil-lkml@...sleyviaduct.com>
To:	linux-kernel@...r.kernel.org
Subject: USB - scanner no longer working on desktop system

My scanner, an Epson Perfection 2400, has recently stopped working on  
my desktop system - it was fine for the last year. It still works on  
my laptop.

Both systems are running Debian lenny, the main difference being the  
kernel version. Currently, the desktop has 2.6.26-19lenny1 - 19lenny2  
and 19 are also listed as available. Due to its Intel 5100 wireless,  
the laptop has a newer kernel - 2.6.30-7~bpo50+1 - with  
2.6.30-8~bpo50+1 also listed as available.

I am not sure if the kernel on the desktop has changed since the  
scanner last worked, but will try the other available versions this  
evening unless I hear that it is a definite hardware fault, which I  
suspect it might be.

The desktop system also has a USB keyboard, trackball and joystick,  
and flash drives also work on it. I have not tried my IDE connector  
recently but that worked last time I tried it. I did have to return  
one of a pair of flash drives, the supplier said the returned one  
worked but replaced it anyway as I had returned only one and kept the  
other, which worked.

When I connect the scanner, or if connected at boot, I would normally  
expect lsusb to show it. If I try it now, it takes a long time to  
return and does not list the scanner.

I have attached a usbmon dump showing what happens when I connect the  
scanner to the desktop, leaving it connected until the lsusb times  
out. (compressed)

I would be grateful if someone could advise. If this is a hardware  
fault, it could only be either the PSU or the motherboard, and I am  
not sure how I could easily determine which. If however it is a kernel  
problem, I can probably find a way to fix it.

Thanks in advance.

(As shown in my signature I am not on the list.)

-- 
Phil Reynolds
mail: phil-lkml@...sleyviaduct.com
Not subscribed to the LKML, please CC me on replies

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.

Download attachment "1.mon.out.bz2" of type "application/x-bzip2" (7958 bytes)

Powered by blists - more mailing lists