lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 11 Nov 2009 08:02:08 +0100
From:	Ingo Molnar <mingo@...e.hu>
To:	"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
Cc:	Joe Perches <joe@...ches.com>, mingo@...hat.com, hpa@...or.com,
	linux-kernel@...r.kernel.org, tglx@...utronix.de,
	linux-tip-commits@...r.kernel.org
Subject: Re: [tip:core/rcu] rcu: Remove inline from forward-referenced
 functions


* Paul E. McKenney <paulmck@...ux.vnet.ibm.com> wrote:

> On Tue, Nov 10, 2009 at 08:50:13PM -0800, Paul E. McKenney wrote:
> > On Tue, Nov 10, 2009 at 07:28:28PM -0800, Joe Perches wrote:
> > > On Tue, 2009-11-10 at 17:42 -0800, Paul E. McKenney wrote:
> > > > On Tue, Nov 10, 2009 at 05:03:41PM -0800, Joe Perches wrote:
> > > > > So maybe rename rcutree_plugin.h to rcutree_plugin.c and
> > > > > #include "rcutree_plugin.c" in rcutree.c instead.
> > > > Hmmm...
> > > 
> > > Perhaps something like this:
> > 
> > While I do very much appreciate your time and attention to this...
> > 
> > My problem with this sort of thing is that when I tried it, it proved
> > fragile.  Small changes required lots of rework of forward declarations.
> > Putting it at the end makes it work very nicely -- the list of forward
> > declarations doubles as documentation for the plugins, and the contents
> > of kernel/rcutree_plugin.h (or .c or whatever, either way I end up
> > violation about the same number of coding guidelines) is independent of
> > rearrangements of kernel/rcutree.c.
> > 
> > The reason that I would really like to keep rcu_bootup_announce() as
> > a function is that it makes it trivial to collect RCU-flavor-dependent
> > boot-time information, if needed for some debugging effort.  If I pull
> > the string out, this sort of thing becomes much more painful.
> 
> And, as noted in our offline conversation, you are absolutely right
> that I need to add __init to both definitions of rcu_bootup_announce(),
> which I will do, with your Suggested-by.
> 
> Fair enough?

Yep, the __init markers are fair enough - but otherwise i wouldnt overdo 
this - a casual glance at rcutree_plugin.h shows that it's special, 
contains an implementation that is included once into kernel/rcutree.c. 
No need for header guards or a rename.

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists