lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Sun, 22 Nov 2009 09:53:50 +0000
From:	David Woodhouse <>
To:	Ilya Loginov <>
Cc:	Andrew Morton <>,, Peter Horton <>,
	"Ed L. Cashin" <>,
	Jens Axboe <>
Subject: Re: [PATCH] mtd: fix mtd_blkdevs problem with caches on some
 architectures (2.6.31)

On Sun, 2009-11-22 at 12:46 +0300, Ilya Loginov wrote:
>  #define flush_dcache_page(page)                        do { } while (0)
>  #define flush_dcache_mmap_lock(mapping)                do { } while (0)
>  #define flush_dcache_mmap_unlock(mapping)      do { } while (0) 

The thing is, having a function called flush_dcache_page() which doesn't
actually flush a page of the dcache is just blatantly stupid.

It's misnamed -- it should probably be called something like
'flush_valiased_dcache_page()' or 'unalias_dcache_page()' instead, since
I believe it's only supposed to cope with aliasing issues with virtually
indexed caches.

If you're talking about _extending_ the existing silly name to a new
ARCH_IMPLEMENTS_FOO macro or Kconfig option, perhaps this would be a
good time to fix the nomenclature, rather than propagating the error?

David Woodhouse                            Open Source Technology Centre                              Intel Corporation

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists