[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20091124204152.GA9131@redhat.com>
Date: Tue, 24 Nov 2009 21:41:52 +0100
From: Oleg Nesterov <oleg@...hat.com>
To: Andi Kleen <andi@...stfloor.org>
Cc: Alexey Dobriyan <adobriyan@...il.com>,
Ananth Mavinakayanahalli <ananth@...ibm.com>,
Christoph Hellwig <hch@...radead.org>,
"Frank Ch. Eigler" <fche@...hat.com>, Ingo@...stfloor.org,
"Molnar <mingo"@firstfloor.org, utrace-devel@...hat.com,
linux-kernel@...r.kernel.org
Subject: Re: [RFC,PATCH 14/14] utrace core
On 11/24, Andi Kleen wrote:
>
> Oleg Nesterov <oleg@...hat.com> writes:
>
> > From: Roland McGrath <roland@...hat.com>
> >
> > This adds the utrace facility, a new modular interface in the kernel
> > for implementing user thread tracing and debugging. This fits on top
> > of the tracehook_* layer, so the new code is well-isolated.
>
> Could we just drop the tracehook layer if this finally merged
> and call the low level functions directly?
Not sure I understand. Tracehooks are trivial inline wrappers on
top utrace calls,
> It might have been reasonably early on when it was still out of tree,
> but longer term when it's integrated having strange opaque hooks
> like that just makes the coder harder to read and maintain.
Well, I don't think the code will be better if we remove tracehooks.
For example. tracehook_report_syscall_entry() has a lot of callers
in arch/, each callsite should be changed to do
if ((task_utrace_flags(current) & UTRACE_EVENT(SYSCALL_ENTRY)) &&
utrace_report_syscall_entry(regs))
ret = -1; // this depends on machine
instead of simply calling tracehook_report_syscall_entry().
What is the point?
But again, perhaps I misunderstood you.
Oleg.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists