[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4B1737E2.6010502@redhat.com>
Date: Wed, 02 Dec 2009 23:00:34 -0500
From: Masami Hiramatsu <mhiramat@...hat.com>
To: Mathieu Desnoyers <mathieu.desnoyers@...ymtl.ca>
CC: Steven Rostedt <rostedt@...dmis.org>, akpm@...ux-foundation.org,
Ingo Molnar <mingo@...e.hu>, mingo@...hat.com, hpa@...or.com,
linux-kernel@...r.kernel.org, randy.dunlap@...cle.com,
wcohen@...hat.com, fweisbec@...il.com, tglx@...utronix.de,
jbaron@...hat.com, linux-tip-commits@...r.kernel.org,
Christoph Hellwig <hch@....de>
Subject: Re: trace/events: DECLARE vs DEFINE semantic
Mathieu Desnoyers wrote:
> In addition, I wonder if we should rename "CREATE_TRACE_POINTS" to
> something more suitable while we are here ? Basically, it will affect
> all TRACE_CLASS/TRACE_CLASS_EVENT/TRACE_EVENT from headers included
> after it's defined.
Agreed, CREATE_TRACE_POINTS is a bit irritating thing :-(
For example, if we call tracepoints defined in same-header on
several different files, we need to check other people have
already defined CREATE_TRACE_POINTS on another file, because
CREATE_TRACE_POINTS must be used once for each header...
So, how about introducing a c file which is only for defining
tracepoints for kernel parts ? or defining tracepoints in
kernel at the beginning of kernel/tracepoint.c ? (and don't
touch tracepoints in modules)
e.g.
@kernel/tracepoint.c
...
#define CREATE_TRACE_POINTS
#include <trace/events/sched.h>
#include <trace/events/...>
...
@kernel/sched.c
...
#include <trace/events/sched.h> /* Just include events header */
...
@fs/ext4/super.c (no change, since it can be module)
...
#define CREATE_TRACE_POINTS
#include <trace/events/ext4.h>
...
Hmm?
Thank you,
--
Masami Hiramatsu
Software Engineer
Hitachi Computer Products (America), Inc.
Software Solutions Division
e-mail: mhiramat@...hat.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists