[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <200912171708.07899.bzolnier@gmail.com>
Date: Thu, 17 Dec 2009 17:08:07 +0100
From: Bartlomiej Zolnierkiewicz <bzolnier@...il.com>
To: Linus Torvalds <torvalds@...ux-foundation.org>
Cc: Américo Wang <xiyou.wangcong@...il.com>,
Mikulas Patocka <mpatocka@...hat.com>,
linux-kernel@...r.kernel.org, Alasdair G Kergon <agk@...hat.com>,
dm-devel@...hat.com
Subject: Re: [PATCH] Drop 80-character limit in checkpatch.pl
On Thursday 17 December 2009 04:37:41 pm Linus Torvalds wrote:
>
> On Thu, 17 Dec 2009, Bartlomiej Zolnierkiewicz wrote:
> >
> > Examples? :)
>
> They're typically things like this:
>
> - ret = sscanf (buf, "0x%lx - 0x%lx", &start_addr, &end_addr);
> + ret = sscanf(buf, "0x%lx - 0x%lx", &start_addr,
> + &end_addr);
>
> ie a line-break that is just annoying and makes the code harder to read
> rather than easier.
Well, it could have been done in the other way:
- ret = sscanf (buf, "0x%lx - 0x%lx", &start_addr, &end_addr);
+ ret = sscanf(buf, "0x%lx - 0x%lx",
+ &start_addr, &end_addr);
Just an example that the limit itself is usually not a problem
but its literal interpretation is..
I don't feel strongly about it the either way so how's about just
adding the switch and than changing the default (Alasdair?) on top
of it?
--
Bartlomiej Zolnierkiewicz
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists