[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20100131190009.b266a27e.akpm@linux-foundation.org>
Date: Sun, 31 Jan 2010 19:00:09 -0800
From: Andrew Morton <akpm@...ux-foundation.org>
To: Akinobu Mita <akinobu.mita@...il.com>
Cc: Alexey Dobriyan <adobriyan@...il.com>,
linux-kernel@...r.kernel.org, Ingo Molnar <mingo@...e.hu>,
Peter Zijlstra <peterz@...radead.org>
Subject: Re: [PATCH 1/7] sched: Use for_each_bit
On Mon, 1 Feb 2010 11:54:14 +0900 Akinobu Mita <akinobu.mita@...il.com> wrote:
> 2010/2/1 Andrew Morton <akpm@...ux-foundation.org>:
> > On Sun, 31 Jan 2010 14:06:10 +0200 Alexey Dobriyan <adobriyan@...il.com> wrote:
> >
> >> On Sun, Jan 31, 2010 at 1:53 PM, Akinobu Mita <akinobu.mita@...il.com> wrote:
> >> > __#define for_each_cpupri_active(array, idx) __ __ __ __ __ __ __ __ __ __\
> >> > - __for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES); __ __ \
> >> > - __ __ __ idx < CPUPRI_NR_PRIORITIES; __ __ __ __ __ __ __ __ __ __ __ __ __ __\
> >> > - __ __ __ idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
> >> > + __ __ __ for_each_bit(idx, array, CPUPRI_NR_PRIORITIES)
> >>
> >> It should be called for_each_set_bit().
> >
> > Agree.
>
> (I'm resending because I failed to reply all)
>
> You mean for_each_bit() should be renamed to for_each_set_bit() ?
Yes.
> I'm not sure. But if so, find_first_bit() also should be renamed to
> find_first_set_bit() and so on?
Yes, it should have been. It's a bit late to correct that mistake, but
it's not too late to fix for_each_bit().
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists