lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 01 Feb 2010 09:25:39 -0800
From:	Joe Perches <joe@...ches.com>
To:	Akinobu Mita <akinobu.mita@...il.com>
Cc:	linux-kernel@...r.kernel.org, akpm@...ux-foundation.org
Subject: Re: [PATCH 1/9] bitops: rename for_each_bit to for_each_set_bit

On Tue, 2010-02-02 at 00:10 +0900, Akinobu Mita wrote:
> Rename for_each_bit to for_each_set_bit in the kernel source tree.

I preferred the for_each_bit because it gives some
naming consistency.

These look for set bits:

        find_first_bit
        find_next_bit
        find_last_bit
        
These look for unset bits:

        find_first_zero_bit
        find_next_zero_bit

I think there should be 3 macros named:
        for_each_bit
        for_each_zero_bit
        for_every_bit

and maybe there's a use for:
        find_last_zero_bit

I think the macro definition should be located
near these other functions in bitops.h and not
placed somewhat randomly near the top of the file.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists