[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20100309174815.29339.96173.stgit@bob.kio>
Date: Tue, 09 Mar 2010 10:52:43 -0700
From: Alex Chiang <achiang@...com>
To: sarah.a.sharp@...ux.intel.com
Cc: linux-usb@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: [PATCH 0/2] small xhci cleanups
While trying to render aid and assistance for a USB3 issue that Sarah
has been chasing, she grumbled in a private email that she was unable
to coerce the build system to produce a module named "xhci_hcd".
This patch series shows one way to get around the Makefile intrinsics
and create a module name of our choosing. There's probably a better
way to do it, but it's beyond my makefile-fu.
The other change is to move all the debug code under
CONFIG_XHCI_HCD_DEBUGGING, which is a straightforward change.
Thanks,
/ac
---
Alex Chiang (2):
USB: xhci: rename driver to xhci_hcd
USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING
drivers/usb/host/Makefile | 7
drivers/usb/host/xhci-dbg.c | 76 ++
drivers/usb/host/xhci-hcd.c | 1806 -------------------------------------------
drivers/usb/host/xhci.c | 1736 +++++++++++++++++++++++++++++++++++++++++
drivers/usb/host/xhci.h | 19
5 files changed, 1836 insertions(+), 1808 deletions(-)
delete mode 100644 drivers/usb/host/xhci-hcd.c
create mode 100644 drivers/usb/host/xhci.c
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists