[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20100323164323.GA2841@joi.lan>
Date: Tue, 23 Mar 2010 17:43:23 +0100
From: Marcin Slusarz <marcin.slusarz@...il.com>
To: Takashi Iwai <tiwai@...e.de>
Cc: Joe Perches <joe@...ches.com>, Dan Carpenter <error27@...il.com>,
Mauro Carvalho Chehab <mchehab@...radead.org>,
Srinivasa Deevi <srinivasa.deevi@...exant.com>,
linux-media@...r.kernel.org, linux-kernel@...r.kernel.org,
kernel-janitors@...r.kernel.org
Subject: Re: [patch v2] cx231xx: card->driver "Conexant cx231xx Audio" too
long
On Mon, Mar 22, 2010 at 05:04:55PM +0100, Takashi Iwai wrote:
> At Mon, 22 Mar 2010 08:43:47 -0700,
> Joe Perches wrote:
> >
> > On Mon, 2010-03-22 at 18:39 +0300, Dan Carpenter wrote:
> > > card->driver is 15 characters and a NULL, the original code could
> > > cause a buffer overflow.
> >
> > > In version 2, I used a better name that Takashi Iwai suggested.
> >
> > Perhaps it's better to use strncpy as well.
>
> strlcpy() would be safer :)
>
> But, in such a case, we want rather that the error is notified at
> build time.
>
> Maybe a macro like below would be helpful to catch such bugs?
>
> #define COPY_STRING(buf, src) \
> do { \
> if (__builtin_constant_p(src)) \
> BUILD_BUG_ON(strlen(src) >= sizeof(buf)); \
> strcpy(buf, src); \
> } while (0)
>
> and used like:
>
> struct foo {
> char foo[5];
> } x;
>
> COPY_STRING(x.foo, "OK"); // OK
> COPY_STRING(x.foo, "1234567890"); // NG
why not define strcpy this way?
Marcin
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists