[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <7838b5aa00b0d48ca0c5970f2d973693dee16be6.1270493677.git.joe@perches.com>
Date: Mon, 5 Apr 2010 12:05:40 -0700
From: Joe Perches <joe@...ches.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-kernel@...r.kernel.org
Subject: [PATCH 10/11] drivers/char/mem.c: Rename dev_info to bdi
There is a macro called dev_info that prints struct device specific
information. Having variables with the same name can be confusing and
prevents conversion of the macro to a function.
Rename the existing dev_info variables to something else in preparation
to converting the dev_info macro to a function.
Signed-off-by: Joe Perches <joe@...ches.com>
---
drivers/char/mem.c | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/char/mem.c b/drivers/char/mem.c
index 1f3215a..cb1d642 100644
--- a/drivers/char/mem.c
+++ b/drivers/char/mem.c
@@ -839,7 +839,7 @@ static const struct memdev {
const char *name;
mode_t mode;
const struct file_operations *fops;
- struct backing_dev_info *dev_info;
+ struct backing_dev_info *bdi;
} devlist[] = {
[1] = { "mem", 0, &mem_fops, &directly_mappable_cdev_bdi },
#ifdef CONFIG_DEVKMEM
@@ -873,8 +873,8 @@ static int memory_open(struct inode *inode, struct file *filp)
return -ENXIO;
filp->f_op = dev->fops;
- if (dev->dev_info)
- filp->f_mapping->backing_dev_info = dev->dev_info;
+ if (dev->bdi)
+ filp->f_mapping->backing_dev_info = dev->bdi;
if (dev->fops->open)
return dev->fops->open(inode, filp);
--
1.7.0.3.311.g6a6955
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists