[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20100416143134.27B9.A69D9226@jp.fujitsu.com>
Date: Fri, 16 Apr 2010 14:33:36 +0900 (JST)
From: KOSAKI Motohiro <kosaki.motohiro@...fujitsu.com>
To: Minchan Kim <minchan.kim@...il.com>
Cc: kosaki.motohiro@...fujitsu.com,
Wu Fengguang <fengguang.wu@...el.com>,
Andreas Mohr <andi@...as.de>, Jens Axboe <axboe@...nel.dk>,
Linux Memory Management List <linux-mm@...ck.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Rik van Riel <riel@...hat.com>,
Lee Schermerhorn <Lee.Schermerhorn@...com>
Subject: Re: [PATCH] vmscan: page_check_references() check low order lumpy reclaim properly
> > + /*
> > + * If we need a large contiguous chunk of memory, or have
> > + * trouble getting a small set of contiguous pages, we
> > + * will reclaim both active and inactive pages.
> > + */
> > + if (sc->order > PAGE_ALLOC_COSTLY_ORDER)
> > + sc->lumpy_reclaim = 1;
> > + else if (sc->order && priority < DEF_PRIORITY - 2)
> > + sc->lumpy_reclaim = 1;
> > + else
> > + sc->lumpy_reclaim = 0;
>
> How about making new function for readability instead of nesting else?
> int is_lumpy_reclaim(struct scan_control *sc)
> {
> ....
> }
>
> If you merge patch reduced stack usage of reclaim path, I think it's
> enough alone scan_control argument.
> It's just nitpick. :)
> If you don't mind, ignore, please.
Good opinion. I don't hope introduce the dependency of "reduced stack usage"
series. but I agree that I'll push your proposal later and separately.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists