lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:	Fri, 23 Apr 2010 13:55:42 +0800
From:	Lin Ming <ming.m.lin@...el.com>
To:	Peter Zijlstra <peterz@...radead.org>,
	Frederic Weisbecker <fweisbec@...il.com>,
	Ingo Molnar <mingo@...e.hu>,
	"eranian@...il.com" <eranian@...il.com>,
	"Gary.Mohr@...l.com" <Gary.Mohr@...l.com>,
	Corey Ashford <cjashfor@...ux.vnet.ibm.com>,
	"arjan@...ux.intel.com" <arjan@...ux.intel.com>,
	"Zhang, Yanmin" <yanmin_zhang@...ux.intel.com>,
	Paul Mackerras <paulus@...ba.org>,
	"David S. Miller" <davem@...emloft.net>
Cc:	lkml <linux-kernel@...r.kernel.org>
Subject: [RFC][PATCH v2 0/4] perf: remove __weak function
 hw_perf_group_sched_in()

Hi, all

>>From the discussion of thread "[RFC] perf_events: support for uncore
a.k.a. nest units", in order to support multiple hw pmu, Peter suggested
the first thing that needs to be done is get rid of all the __weak
functions (with exception of perf_callchain*, since that really is arch
specific), includes

hw_perf_group_sched_in
hw_perf_event_init
hw_perf_disable
hw_perf_enable

Peter Zijlstra <peterz@...radead.org> wrote:
> One thing not on that list, which should happen first I guess, is to
> remove hw_perf_group_sched_in(). The idea is to add some sort of
> transactional API to the struct pmu, so that we can delay the
> schedulability check until commit time (and roll back when it fails).
>
> Something as simple as:
>
>  struct pmu {
>    void start_txn(struct pmu *);
>    void commit_txn(struct pmu *);
>
>    ,,,
>  };
>
> and then change group_sched_in() to use this instead of
> hw_perf_group_sched_in(), whose implementations mostly replicate
> group_sched_in() in various buggy ways anyway.
>

This patch series is to remove hw_perf_group_sched_in() first.

patch 1: core, add group scheduling transactional APIs
patch 2: x86, implement group scheduling transactional APIs
patch 3: powerpc, implement group scheduling transactional APIs
patch 4: sparc, implement group scheduling transactional APIs

I have tested these patches on x86, but for powerpc and sparc it's only
cross build tested.
It's very appreciated if anybody has powerpc or sparc can help to test. 

Thanks for any comment.

Changes log:

v2.
Change transaction flag(cpu_hw_events->group_flag) from u8 to unsigned
int. RISC architecture deals better with word sized variable than u8.
(Peter Zijlstra)

Rename callback names, *_txn -> *_group_trans for better readability.
Add a few comments to describe the callbacks. (Frederic Weisbecker)

v1.
remove __weak function hw_perf_group_sched_in() based on Peter's idea.

Thanks,
Lin Ming

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ