lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Wed, 12 May 2010 10:20:38 +0200 (CEST)
From:	Jiri Kosina <jkosina@...e.cz>
To:	Morgan Gatti <morgan.gatti@...il.com>
Cc:	gregkh@...e.de, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Staging:comedi:Fix bug and coding style issue in usbdux.c
 This is a patch to the usbdux.c file that resolve 2 errors in coding and
 fix the warning about lengt of code lines Signed-off-by: Morgan Gatti
 <morgan.gatti@...il.com>

On Tue, 11 May 2010, Morgan Gatti wrote:

> ---
>  drivers/staging/comedi/drivers/usbdux.c |   10 +++++-----
>  1 files changed, 5 insertions(+), 5 deletions(-)

Morgan,

please look into fixing you patch submission tools -- the whole changelog, 
including your Signed-off-by: line, ended up in Subject:, which is 
probably not what you intended.

> diff --git a/drivers/staging/comedi/drivers/usbdux.c b/drivers/staging/comedi/drivers/usbdux.c
> index 8942ae4..c39c36a 100644
> --- a/drivers/staging/comedi/drivers/usbdux.c
> +++ b/drivers/staging/comedi/drivers/usbdux.c
> @@ -793,7 +793,7 @@ static int usbduxsub_stop(struct usbduxsub *usbduxsub)
>  }
>  
>  static int usbduxsub_upload(struct usbduxsub *usbduxsub,
> -			    uint8_t * local_transfer_buffer,
> +			    uint8_t *local_transfer_buffer,
>  			    unsigned int startAddr, unsigned int len)
>  {
>  	int errcode;
> @@ -825,7 +825,7 @@ static int usbduxsub_upload(struct usbduxsub *usbduxsub,
>  #define FIRMWARE_MAX_LEN 0x2000
>  
>  static int firmwareUpload(struct usbduxsub *usbduxsub,
> -			  const u8 * firmwareBinary, int sizeFirmware)
> +			  const u8 *firmwareBinary, int sizeFirmware)

While you are performing the glorious task of fixing the coding style in 
this driver, maybe also converting it not to use CamelNamingConvention 
would be worthwile.

>  {
>  	int ret;
>  	uint8_t *fwBuf;
> @@ -835,7 +835,7 @@ static int firmwareUpload(struct usbduxsub *usbduxsub,
>  
>  	if (sizeFirmware > FIRMWARE_MAX_LEN) {
>  		dev_err(&usbduxsub->interface->dev,
> -			"comedi_: usbdux firmware binary it too large for FX2.\n");
> +		"comedi_: usbdux firmware binary it too large for FX2.\n");
>  		return -ENOMEM;
>  	}
>  
> @@ -1264,8 +1264,8 @@ static int usbdux_ai_cmd(struct comedi_device *dev, struct comedi_subdevice *s)
>  			    (this_usbduxsub->ai_interval) * 2;
>  		}
>  		this_usbduxsub->ai_timer = cmd->scan_begin_arg / (125000 *
> -								  (this_usbduxsub->
> -								   ai_interval));
> +					  (this_usbduxsub->
> +					   ai_interval));

Pasting this to one line would improve readability.

-- 
Jiri Kosina
SUSE Labs, Novell Inc.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ