[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20100619104439.GA7659@lst.de>
Date: Sat, 19 Jun 2010 12:44:39 +0200
From: Christoph Hellwig <hch@....de>
To: Michael Rubin <mrubin@...gle.com>
Cc: linux-kernel@...r.kernel.org, linux-fsdevel@...r.kernel.org,
linux-mm@...ck.org, jack@...e.cz, akpm@...ux-foundation.org,
david@...morbit.com, hch@....de, axboe@...nel.dk
Subject: Re: [PATCH 1/3] writeback: Creating /sys/kernel/mm/writeback/writeback
On Fri, Jun 18, 2010 at 05:30:13PM -0700, Michael Rubin wrote:
> Adding the /sys/kernel/mm/writeback/writeback file. It contains data
> to help developers and applications gain visibility into writeback
> behaviour.
>
> # cat /sys/kernel/mm/writeback/writeback
> pages_dirtied: 3747
> pages_cleaned: 3618
> dirty_threshold: 816673
> bg_threshold: 408336
I'm fine with exposting this. but the interface is rather awkward.
These kinds of multiple value per file interface require addition
parsing and are a pain to extend. Please do something like
/proc/sys/vm/writeback/
pages_dirtied
pages_cleaned
dirty_threshold
background_threshold
where you can just read the value from the file.
> diff --git a/fs/nilfs2/segment.c b/fs/nilfs2/segment.c
> index c920164..84b0181 100644
> --- a/fs/nilfs2/segment.c
> +++ b/fs/nilfs2/segment.c
> @@ -1598,8 +1598,10 @@ nilfs_copy_replace_page_buffers(struct page *page, struct list_head *out)
> } while (bh = bh->b_this_page, bh2 = bh2->b_this_page, bh != head);
> kunmap_atomic(kaddr, KM_USER0);
>
> - if (!TestSetPageWriteback(clone_page))
> + if (!TestSetPageWriteback(clone_page)) {
> inc_zone_page_state(clone_page, NR_WRITEBACK);
> + inc_zone_page_state(clone_page, NR_PAGES_ENTERED_WRITEBACK);
> + }
> unlock_page(clone_page);
I'm not very happy about having this opencoded in a filesystem.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists