[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <AANLkTinMLrXyqKZ76AiWiw6N_glrWWrP-2_aUTzQm5Xr@mail.gmail.com>
Date: Mon, 28 Jun 2010 12:55:45 +0800
From: Eric Miao <eric.y.miao@...il.com>
To: Uwe Kleine-König
<u.kleine-koenig@...gutronix.de>
Cc: Greg KH <greg@...ah.com>, Randy Dunlap <rdunlap@...otime.net>,
Dmitry Torokhov <dtor@...l.ru>,
Anisse Astier <anisse@...ier.eu>,
Greg Kroah-Hartman <gregkh@...e.de>,
Magnus Damm <damm@...nsource.se>,
"Rafael J. Wysocki" <rjw@...k.pl>,
Paul Mundt <lethal@...ux-sh.org>, linux-doc@...r.kernel.org,
linux-kernel@...r.kernel.org, netdev@...r.kernel.org
Subject: Re: [PATCH 2/2 v2] Driver core: reduce duplicated code
2010/6/22 Uwe Kleine-König <u.kleine-koenig@...gutronix.de>:
> Hi Greg,
>
>> > I changed the semantic slightly to only call
>> > platform_device_add_resources if data != NULL instead of size != 0. The
>> > idea is to support wrappers like:
>> >
>> > #define add_blablub(id, pdata) \
>> > platform_device_register_resndata(NULL, "blablub", id, \
>> > NULL, 0, pdata, sizeof(struct blablub_platform_data))
>> >
>> > that don't fail if pdata=NULL. Ditto for res.
>>
>> That's fine, but why would you want to have a #define for something like
>> this? Is it really needed?
> Well, what is really needed? I intend to use it on arm/imx. I have
> several different machines using similar SoCs and so I want to have a
> function à la:
>
> struct platform_device *__init imx_add_imx_i2c(int id,
> resource_size_t iobase, resource_size_t iosize, int irq,
> const struct imxi2c_platform_data *pdata)
>
> that builds a struct resource[] and then calls
> platform_device_register_resndata(). And then I have a set of macros
> like:
>
> #define imx21_add_i2c_imx(pdata) \
> imx_add_imx_i2c(0, MX2x_I2C_BASE_ADDR, SZ_4K, MX2x_INT_I2C, pdata)
> #define imx25_add_imx_i2c0(pdata) \
> imx_add_imx_i2c(0, MX25_I2C1_BASE_ADDR, SZ_16K, MX25_INT_I2C1, pdata)
> ##define imx25_add_imx_i2c1(pdata) \
> imx_add_imx_i2c(1, MX25_I2C2_BASE_ADDR, SZ_16K, MX25_INT_I2C2, pdata)
>
> etc. The final goal is to get rid of files like
> arch/arm/mach-mx3/devices.c.
>
Hi Uwe,
I suggest you to have a look into arch/arm/mach-mmp/devices.c and
arch/arm/mach-mmp/pxa{168,910}.c as well as
arch/arm/mach-mmp/include/mach/pxa{168,910}.h, maybe we can find
some common practice.
>> Anyway, this version looks fine to me, I'll go apply it.
> \o/
>
> Best regards and thanks
> Uwe
>
> --
> Pengutronix e.K. | Uwe Kleine-König |
> Industrial Linux Solutions | http://www.pengutronix.de/ |
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists