[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <201007152051.18189.PeterHuewe@gmx.de>
Date: Thu, 15 Jul 2010 20:51:17 +0200
From: Peter Huewe <PeterHuewe@....de>
To: Kernel Janitors <kernel-janitors@...r.kernel.org>
Cc: Jens Axboe <jens.axboe@...cle.com>,
Andrew Morton <akpm@...ux-foundation.org>,
" Márton Németh"
<nm127@...email.hu>,
"Martin K. Petersen" <martin.petersen@...cle.com>,
Alexey Dobriyan <adobriyan@...il.com>,
linux-kernel@...r.kernel.org
Subject: [PATCH 11/25] block: Convert pci_table entries to PCI_VDEVICE (if PCI_ANY_ID is used)
From: Peter Huewe <peterhuewe@....de>
This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
.subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
PCI_VDEVICE macro, and thus improves readability.
Signed-off-by: Peter Huewe <peterhuewe@....de>
---
drivers/block/sx8.c | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/block/sx8.c b/drivers/block/sx8.c
index b70f0fc..15745e4 100644
--- a/drivers/block/sx8.c
+++ b/drivers/block/sx8.c
@@ -410,8 +410,8 @@ static void carm_remove_one (struct pci_dev *pdev);
static int carm_bdev_getgeo(struct block_device *bdev, struct hd_geometry *geo);
static const struct pci_device_id carm_pci_tbl[] = {
- { PCI_VENDOR_ID_PROMISE, 0x8000, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
- { PCI_VENDOR_ID_PROMISE, 0x8002, PCI_ANY_ID, PCI_ANY_ID, 0, 0, },
+ { PCI_VDEVICE(PROMISE, 0x8000), },
+ { PCI_VDEVICE(PROMISE, 0x8002), },
{ } /* terminate list */
};
MODULE_DEVICE_TABLE(pci, carm_pci_tbl);
--
1.7.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists