lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 21 Jul 2010 14:34:23 -0700
From:	Andrew Morton <akpm@...ux-foundation.org>
To:	Jason Baron <jbaron@...hat.com>
Cc:	linux-kernel@...r.kernel.org, andi@...stfloor.org, hare@...e.de,
	trenn@...e.de, yehuda@...newdream.net, stable@...nel.org
Subject: Re: [PATCH] dynamic debug: move ddebug_remove_module() down into
 free_module()

On Wed, 14 Jul 2010 16:00:57 -0400
Jason Baron <jbaron@...hat.com> wrote:

> move the call to ddebug_remove_module() down into free_module(). In this way
> it should be called from all error paths. Currently, we are missing the
> remove if the module init routine fails.
> 
> Signed-off-by: Jason Baron <jbaron@...hat.com>
> Reported-by: Thomas Renninger <trenn@...e.de>
> Tested-by: Thomas Renninger <trenn@...e.de>
> CC: akpm@...ux-foundation.org
> CC: andi@...stfloor.org
> CC: hare@...e.de
> CC: trenn@...e.de
> CC: yehuda@...newdream.net
> CC: linux-kernel@...r.kernel.org

Crappy changelog doesn't describe the bug we're fixing.  It should.

It's

	echo "file ec.c +p" >/sys/kernel/debug/dynamic_debug/control

causes an oops, yes?

> diff --git a/kernel/module.c b/kernel/module.c
> index 5d2d281..6c56282 100644
> --- a/kernel/module.c
> +++ b/kernel/module.c
> @@ -787,7 +787,6 @@ SYSCALL_DEFINE2(delete_module, const char __user *, name_user,
>  
>  	/* Store the name of the last unloaded module for diagnostic purposes */
>  	strlcpy(last_unloaded_module, mod->name, sizeof(last_unloaded_module));
> -	ddebug_remove_module(mod->name);
>  
>  	free_module(mod);
>  	return 0;
> @@ -1550,6 +1549,9 @@ static void free_module(struct module *mod)
>  	remove_sect_attrs(mod);
>  	mod_kobject_remove(mod);
>  
> +	/* Remove dynamic debug info */
> +	ddebug_remove_module(mod->name);
> +
>  	/* Arch-specific cleanup. */
>  	module_arch_cleanup(mod);

Should we backport this into 2.6.34.x?  Earlier?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ