[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <4C5607C8.4090708@pobox.com>
Date: Sun, 01 Aug 2010 19:48:24 -0400
From: Jeff Garzik <jgarzik@...ox.com>
To: Peter Huewe <PeterHuewe@....de>
CC: Kernel Janitors <kernel-janitors@...r.kernel.org>,
Tejun Heo <tj@...nel.org>,
Sergei Shtylyov <sshtylyov@...mvista.com>,
linux-ide@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 04/25] ata: Convert pci_table entries to PCI_VDEVICE (if
PCI_ANY_ID is used)
On 07/15/2010 02:39 PM, Peter Huewe wrote:
> From: Peter Huewe<peterhuewe@....de>
>
> This patch converts pci_table entries, where .subvendor=PCI_ANY_ID and
> .subdevice=PCI_ANY_ID, .class=0 and .class_mask=0, to use the
> PCI_VDEVICE macro, and thus improves readability.
>
> Signed-off-by: Peter Huewe<peterhuewe@....de>
> ---
> drivers/ata/pata_scc.c | 3 +--
> 1 files changed, 1 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/ata/pata_scc.c b/drivers/ata/pata_scc.c
> index d9db3f8..fe36966 100644
> --- a/drivers/ata/pata_scc.c
> +++ b/drivers/ata/pata_scc.c
> @@ -168,8 +168,7 @@ static const unsigned long JCACTSELtbl[2][7] = {
> };
>
> static const struct pci_device_id scc_pci_tbl[] = {
> - {PCI_VENDOR_ID_TOSHIBA_2, PCI_DEVICE_ID_TOSHIBA_SCC_ATA,
> - PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
> + { PCI_VDEVICE(TOSHIBA_2, PCI_DEVICE_ID_TOSHIBA_SCC_ATA), 0},
> { } /* terminate list */
applied
I would prefer to leave ata_piix as it is, though. It's nice and
manageable :)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists