[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <AANLkTinWQ8Td6LcUGn3RmAyDuL0o35-YtjFtpNwJOb3M@mail.gmail.com>
Date: Mon, 2 Aug 2010 16:09:32 -0300
From: Thiago Farina <tfransosi@...il.com>
To: "H. Peter Anvin" <hpa@...or.com>
Cc: Yinghai Lu <yinghai@...nel.org>, Ingo Molnar <mingo@...e.hu>,
Thomas Gleixner <tglx@...utronix.de>,
Cyrill Gorcunov <gorcunov@...nvz.org>,
Pekka Enberg <penberg@...helsinki.fi>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] x86, setup: reorgize the early_console_setup
On Mon, Aug 2, 2010 at 3:27 PM, H. Peter Anvin <hpa@...or.com> wrote:
> On 08/02/2010 10:56 AM, Thiago Farina wrote:
>>
>> These to functions above can be fairly simplified by writting as:
>>
>> static bool inline is_hex_digit(int c) {
>> return (c >= '0' && c <= '9') ||
>> (c >= 'A' && c <= 'F') ||
>> (c >= 'a' && c <= 'f');
>> }
>>
>
> a) You lose the isdigit() functionality, which is useful on its own.
> b) Does this enahance readability in any way?
> c) Your proposed renaming is nonstandard.
>
What about this instead?
static inline bool isxdigit(int ch) {
return (isdigit(ch) || (ch >= 'A' && ch <= 'F') || (ch >= 'a' && ch <= 'f');
}
> As such, I don't think this is a good idea.
>
> -hpa
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists