[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <AANLkTi=jmV=x2rJ=G4iicYFO6UqPbfob_VnkY7VNbP3X@mail.gmail.com>
Date: Mon, 13 Sep 2010 01:20:36 +0900
From: Minchan Kim <minchan.kim@...il.com>
To: Andrew Morton <akpm@...ux-foundation.org>
Cc: Johannes Weiner <hannes@...xchg.org>,
linux-mm <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>,
KOSAKI Motohiro <kosaki.motohiro@...fujitsu.com>,
Rik van Riel <riel@...hat.com>,
"Rafael J. Wysocki" <rjw@...k.pl>,
"M. Vefa Bicakci" <bicave@...eronline.com>, stable@...nel.org
Subject: Re: [PATCH] vmscan: check all_unreclaimable in direct reclaim path
On Thu, Sep 9, 2010 at 7:19 AM, Andrew Morton <akpm@...ux-foundation.org> wrote:
> On Thu, 9 Sep 2010 00:45:27 +0900
> Minchan Kim <minchan.kim@...il.com> wrote:
>
>> +static inline bool zone_reclaimable(struct zone *zone)
>> +{
>> + return zone->pages_scanned < zone_reclaimable_pages(zone) * 6;
>> +}
>> +
>> +static inline bool all_unreclaimable(struct zonelist *zonelist,
>> + struct scan_control *sc)
>> +{
>> + struct zoneref *z;
>> + struct zone *zone;
>> + bool all_unreclaimable = true;
>> +
>> + if (!scanning_global_lru(sc))
>> + return false;
>> +
>> + for_each_zone_zonelist_nodemask(zone, z, zonelist,
>> + gfp_zone(sc->gfp_mask), sc->nodemask) {
>> + if (!populated_zone(zone))
>> + continue;
>> + if (!cpuset_zone_allowed_hardwall(zone, GFP_KERNEL))
>> + continue;
>> + if (zone_reclaimable(zone)) {
>> + all_unreclaimable = false;
>> + break;
>> + }
>> + }
>> +
>> return all_unreclaimable;
>> }
>
> Could we have some comments over these functions please? Why they
> exist, what problem they solve, how they solve them, etc. Stuff which
> will be needed for maintaining this code three years from now.
>
> We may as well remove the `inline's too. gcc will tkae care of that.
Okay. I will resend.
>
>> - if (nr_slab == 0 &&
>> - zone->pages_scanned >= (zone_reclaimable_pages(zone) * 6))
>> + if (nr_slab == 0 && !zone_reclaimable(zone))
>
> Extra marks for working out and documenting how we decided on the value
> of "6". Sigh. It's hopefully in the git record somewhere.
>
Originally it is just following as.
if (zone->pages_scanned > zone->present_pages * 2)
zone->all_unreclaimable = 1;
Nick change it with remained lru * 4 [1] and increased 6 [2].
But the description doesn't have why we determine it by "4".
So I can't handle it in my patch.
I don't like undocumented magic value. :(
[1]
commit 9d0aa0f7a99c88dd20bc188756b892f174d93fc1
Author: nickpiggin <nickpiggin>
Date: Sun Oct 17 16:20:56 2004 +0000
[PATCH] kswapd lockup fix
Fix some bugs in the kswapd logic which can cause kswapd lockups.
[2]
commit 4ff1ffb4870b007b86f21e5f27eeb11498c4c077
Author: Nick Piggin <npiggin@...e.de>
Date: Mon Sep 25 23:31:28 2006 -0700
[PATCH] oom: reclaim_mapped on oom
--
Kind regards,
Minchan Kim
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists