[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20100920121446.18fb3a65.akpm@linux-foundation.org>
Date: Mon, 20 Sep 2010 12:14:46 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Peter Zijlstra <a.p.zijlstra@...llo.nl>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
Ingo Molnar <mingo@...e.hu>,
Thomas Gleixner <tglx@...utronix.de>,
linux-kernel@...r.kernel.org, Jens Axboe <axboe@...nel.dk>,
Tejun Heo <tj@...nel.org>, Avi Kivity <avi@...hat.com>
Subject: Re: [RFC][PATCH 2/2] kernel: extract thread types from
task_struct::flags
On Mon, 20 Sep 2010 17:13:36 +0200
Peter Zijlstra <a.p.zijlstra@...llo.nl> wrote:
> Free up a few more PF_flags by moving thread types out to their own variable.
>
> Initially I compressed the types into less bits inside task_struct::flags, but
> Thomas suggested I move them to their own field.
>
There doesn't seem to be a huge point to all this, but I guess there's
some sense in separating "what type of thread this is" from "attributes
of this thread". Maybe. At the expense of a larger task_struct.
> +/*
> + * Types >= tt_kernel imply the old PF_KTHREAD
> + */
Perhaps that should be encapsulated into another helper function
> --- linux-2.6.orig/kernel/fork.c
> +++ linux-2.6/kernel/fork.c
> @@ -570,7 +570,7 @@ struct mm_struct *get_task_mm(struct tas
> task_lock(task);
> mm = task->mm;
> if (mm) {
> - if (task->flags & PF_KTHREAD)
> + if (task_type(task) >= tt_kernel)
rather than open-coded everywhere.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists