[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20100928153247.GL26290@redhat.com>
Date: Tue, 28 Sep 2010 11:32:47 -0400
From: Don Zickus <dzickus@...hat.com>
To: Huang Ying <ying.huang@...el.com>
Cc: Robert Richter <robert.richter@....com>,
huang ying <huang.ying.caritas@...il.com>,
Ingo Molnar <mingo@...e.hu>, "H. Peter Anvin" <hpa@...or.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
Andi Kleen <andi@...stfloor.org>
Subject: Re: [PATCH -v2 6/7] x86, NMI, Add support to notify hardware error
with unknown NMI
On Tue, Sep 28, 2010 at 08:36:12AM +0800, Huang Ying wrote:
> > I tend to agree with Robert here. I don't know if there were any 'rules'
> > to which handlers get directly called versus ones that go through the
> > die_chain, so I was originally going to let it go. But if they aren't
> > any, it does look cleaner to have everything in die_chains.
>
> Personally, I think directly call has better readability than
I am confused what type of readability you are looking for? Can we create
a sysfs entry to give you that info?
> notifier_chain in general. Notifier_chain is for:
>
> - Call functions in module.
> - Need to enable/disable (via register/unregister) at run time.
> - Call functions from low layer to high layer.
>
> Otherwise, notifier_chain should be avoid if possible. So I think it is
> better to keep direct call as much as possible.
But the problem is you have to export all this platform specific stuff to
traps.c and surround the code with #ifdef's, which start to look ugly.
Is there any reason why traps.c should know about MCA/HEST/<other hardware
errors>? Shouldn't it be abstracted away?
Honestly, I would be interested in creating a southbridge driver and
moving the port 0x61 code there and keeping the default_do_nmi() function
stupidly simple (just a call to the die_chain and the
unknown_nmi_error()).
Just my two cents.
Cheers,
Don
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists