lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 14 Oct 2010 10:09:43 +0300
From:	Pekka Enberg <penberg@...nel.org>
To:	Richard Kennedy <richard@....demon.co.uk>
CC:	Christoph Lameter <cl@...ux-foundation.org>,
	lkml <linux-kernel@...r.kernel.org>,
	linux-mm <linux-mm@...ck.org>,
	Steven Rostedt <rostedt@...dmis.org>
Subject: Re: [PATCH] [RFC] slub tracing: move trace calls out of always inlined
 functions to reduce kernel code size

  On 10/13/10 7:09 PM, Richard Kennedy wrote:
> Having the trace calls defined in the always inlined kmalloc functions
> in include/linux/slub_def.h causes a lot of code duplication as the
> trace functions get instantiated for each kamalloc call site. This can
> simply be removed by pushing the trace calls down into the functions in
> slub.c.
>
> On my x86_64 built this patch shrinks the code size of the kernel by
> approx 29K and also shrinks the code size of many modules -- too many to
> list here ;)
>
> size vmlinux.o reports
>         text	   data	    bss	    dec	    hex	filename
>      4777011	 602052	 763072	6142135	 5db8b7	vmlinux.o
>      4747120	 602388	 763072	6112580	 5d4544	vmlinux.o.patch

Impressive kernel text savings!

> index 13fffe1..32b89ee 100644
> --- a/mm/slub.c
> +++ b/mm/slub.c
> +void *kmalloc_order(size_t size, gfp_t flags, unsigned int order)
> +{
> +	void *ret = (void *) __get_free_pages(flags | __GFP_COMP, order);
> +
> +	kmemleak_alloc(ret, size, 1, flags);
> +	trace_kmalloc(_RET_IP_, ret, size, PAGE_SIZE<<  order, flags);
> +
> +	return ret;
> +}
> +EXPORT_SYMBOL(kmalloc_order);
> +
This doesn't make sense to be out-of-line for the !CONFIG_TRACE case. 
I'd just wrap that with "#ifdef CONFIG_TRACE" and put an inline version 
in the header for !TRACE.

             Pekka
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ