lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20101021080526.GB8775@elte.hu>
Date:	Thu, 21 Oct 2010 10:05:26 +0200
From:	Ingo Molnar <mingo@...e.hu>
To:	Grant Likely <grant.likely@...retlab.ca>
Cc:	Stephen Rothwell <sfr@...b.auug.org.au>,
	linux-next@...r.kernel.org, linux-kernel@...r.kernel.org,
	Andres Salomon <dilinger@...ued.net>,
	Andrew Morton <akpm@...ux-foundation.org>
Subject: Re: linux-next: build warning after merge of the devicetree tree


* Grant Likely <grant.likely@...retlab.ca> wrote:

> On Thu, Oct 21, 2010 at 01:37:26PM +1100, Stephen Rothwell wrote:
> > Hi Grant,
> > 
> > After merging the devicetree tree, today's linux-next build (x86_64
> > allmodconfig) produced this warning:
> > 
> > arch/x86/kernel/irq.c:280: warning: 'struct device_node' declared inside parameter list
> > 
> > Introduced by commit 27f4e2b1060be8bc38146fd30986e7c2858e2a5f ("x86/of:
> > define irq functions to allow drivers/of/* to build on x86").  This build
> > has CONFIG_OF not set.
> 
> Thanks Stephen.  Does the following patch fix things?
> 
> diff --git a/arch/x86/kernel/irq.c b/arch/x86/kernel/irq.c
> index 4417f49..23216f7 100644
> --- a/arch/x86/kernel/irq.c
> +++ b/arch/x86/kernel/irq.c
> @@ -276,12 +276,14 @@ void smp_x86_platform_ipi(struct pt_regs *regs)
>  
>  EXPORT_SYMBOL_GPL(vector_used_by_percpu_irq);
>  
> +#ifdef CONFIG_OF
>  unsigned int irq_create_of_mapping(struct device_node *controller,
>                 const u32 *intspec, unsigned int intsize)
>  {
>         return intspec[0];
>  }
>  EXPORT_SYMBOL_GPL(irq_create_of_mapping);
> +#endif

Sigh, 'of' is the most misnamed Linux subsystem in history! 'CONFIG_OF_' always 
makes me ask 'config of what?' irq_create_of_mapping ditto.

Why not OFW or OPENFIRMWARE?

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ