[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <x49fwvz1o8c.fsf@segfault.boston.devel.redhat.com>
Date: Thu, 21 Oct 2010 12:53:39 -0400
From: Jeff Moyer <jmoyer@...hat.com>
To: Vivek Goyal <vgoyal@...hat.com>
Cc: Andi Kleen <ak@...ux.intel.com>, Jens Axboe <axboe@...nel.dk>,
Andi Kleen <andi@...stfloor.org>,
torvalds@...ux-foundation.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Fix array overflow in CFQ
Vivek Goyal <vgoyal@...hat.com> writes:
> On Tue, Oct 19, 2010 at 03:23:22PM +0200, Andi Kleen wrote:
>>
>> > slice = group_slice * count /
>> > max_t(unsigned, cfqg->busy_queues_avg[cfqd->serving_prio],
>> > cfq_group_busy_queues_wl(cfqd->serving_prio, cfqd,
>> >cfqg));
>> >
>> >So for IDLE class, we return immediately from the function and never
>> >execute cfqg->busy_queues_avg[IDLE].
>>
>> Hmm that's true. But why do you put this into a global variable
>> anyways, can't it
>> just be a local?
>
> We keep track of average number of queues per group per prio class. So it
> can't be local as it historical data.
>
>> >Now to remove the gcc warning we can increase the size of busy_queues_avg[]
>> >array but third field should always remain unused.
>> >
>> It's better to increase the field still I think.
>
> Agreed.
>
> Jens, do you want me to regenerate your patch so that we increase the
> size of ->busy_queues_avg[CFQ_PRIO_NR] but not ->service_trees[][].
Just be sure to put a huge comment in there so you don't confuse the
poor masses trying to make sense of the code.
Cheers,
Jeff
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists