[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20101118083045.GB26398@elte.hu>
Date: Thu, 18 Nov 2010 09:30:45 +0100
From: Ingo Molnar <mingo@...e.hu>
To: Tejun Heo <tj@...nel.org>
Cc: linux-kernel@...r.kernel.org, mingo@...hat.com, tglx@...utronix.de,
hpa@...or.com, x86@...nel.org, eric.dumazet@...il.com,
yinghai@...nel.org
Subject: Re: [PATCH 4/9 UPDATED-1] x86: Initialize 32bit logical apicid
mapping early during boot
* Tejun Heo <tj@...nel.org> wrote:
> On x86_32, non-standard logical apicid mapping can be used by
> different NUMA setups and the mapping is queried while bringing up
> each CPU using apic->cpu_to_logical_apicid() to build
> cpu_2_logical_apicid[] array. The logical apicid is then used to
> deliver IPIs and determine NUMA configuration.
>
> Unfortunately, initializing at SMP bring up is too late for percpu
> setup making static percpu variables setup w/o considering NUMA. This
> also is different from how x86_64 is configured making the code
> difficult to follow and maintain.
>
> This patch updates logical apicid mapping handling such that,
>
> * early_percpu variable x86_cpu_to_logical_apicid replaces
> cpu_2_logical_apicid[].
>
> * apic->cpu_to_logical_apicid() is called once during get_smp_config()
> and the output is recorded in x86_cpu_to_logical_apicid.
>
> * apic->cpu_to_logical_apicid() is allowed to return BAD_APICID if it
> can't determine the value that early during boot. In this case, the
> mapping will be initialized during SMP bring up by reading APIC LDR
> as before.
>
> - Brian Gerst spotted that setup_per_cpu_areas() was not copying the
> early x86_cpu_to_logical_apicid to the permanent percpu area and
> es7000_32 is using per_cpu() instead of early_per_cpu(), which in
> itself is not incorrect as they're never used before setup_per_cpu()
> but still confusing. Both updated.
>
> - Using local variable @cpu to cache smp_processor_id() in
> setup_local_APIC() separated out into a separate patch as suggested
> by Yinghai Lu.
This patch is still _WAY_ too large.
Also, these:
> +#ifdef CONFIG_X86_32
> +#endif
> +#ifdef CONFIG_X86_32
> +#endif
> +#ifdef CONFIG_X86_32
> +#endif
> +#ifdef CONFIG_X86_32
> +#endif
Are rather ugly.
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists