lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Fri, 28 Jan 2011 10:05:07 +0100
From:	Miguel Ojeda <miguel.ojeda.sandonis@...il.com>
To:	Rogério Brito <rbrito@....usp.br>
Cc:	linux-kernel@...r.kernel.org,
	Alexander Holler <holler@...oftware.de>,
	"Gustavo F. Padovan" <padovan@...fusion.mobi>
Subject: Re: [PATCH 01/02] ath3k: Avoid duplication of code

Hi,

2011/1/28 Rogério Brito <rbrito@....usp.br>:
> Hi.
>
> In commit 86e09287e4f8c81831b4d4118a48597565f0d21b, to reduce memory
> usage, the functions of the ath3k module were rewritten to release the
> firmware blob after it has been loaded (successfully or not).
>
> The resuting code has some redundancy and the compiler can potentially
> produce better code if we omit a function call that is unconditionally
> executed in
>
> ,----
> |       if (ath3k_load_firmware(udev, firmware)) {
> |               release_firmware(firmware);
> |               return -EIO;
> |       }
> |       release_firmware(firmware);
> |
> |       return 0;
> | }
> `----
>
> It may also be argued that the rewritten code becomes easier to read,
> and also to see the code coverage of the snippet in question.
>
>
> Signed-off-by: Rogério Brito <rbrito@....usp.br>
>
> ---
>
> I am sending here two proposals for rewriting the code.  This is the
> first one. The second uses the ternary operator and seems to have more
> usage in the kernel (or, at least, under mm).
>
> ---
>
> diff --git a/drivers/bluetooth/ath3k.c b/drivers/bluetooth/ath3k.c
> index a126e61..0043781 100644
> --- a/drivers/bluetooth/ath3k.c
> +++ b/drivers/bluetooth/ath3k.c
> @@ -116,13 +116,13 @@ static int ath3k_probe(struct usb_interface *intf,
>                return -EIO;
>        }
>
> -       if (ath3k_load_firmware(udev, firmware)) {
> -               release_firmware(firmware);
> -               return -EIO;
> -       }
> +       ret = ath3k_load_firmware(udev, firmware);
>        release_firmware(firmware);
>
> -       return 0;
> +       if (ret)
> +               return -EIO;
> +       else
> +               return 0;

We don't need "else" after a return statement, in order to avoid a
indentation level.

>  }
>
>  static void ath3k_disconnect(struct usb_interface *intf)
> --
> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to majordomo@...r.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ