[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4D4B27F5.8020701@zytor.com>
Date: Thu, 03 Feb 2011 14:11:01 -0800
From: "H. Peter Anvin" <hpa@...or.com>
To: Ingo Molnar <mingo@...e.hu>
CC: castet.matthieu@...e.fr,
Linux Kernel list <linux-kernel@...r.kernel.org>,
linux-security-module@...r.kernel.org,
Matthias Hopf <mhopf@...e.de>, rjw@...k.pl,
Andrew Morton <akpm@...ux-foundation.org>,
Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH] NX protection for kernel data : fix 32 bits S3 suspend
On 02/01/2011 10:26 PM, Ingo Molnar wrote:
>
> * castet.matthieu@...e.fr <castet.matthieu@...e.fr> wrote:
>
>> Quoting Ingo Molnar <mingo@...e.hu>:
>>
>>>
>>> * matthieu castet <castet.matthieu@...e.fr> wrote:
>>>
>>>> static inline int is_kernel_text(unsigned long addr)
>>>> {
>>>> +#if defined(CONFIG_X86_32) && defined(CONFIG_ACPI_SLEEP)
>>>> + /*
>>>> + * We need to make the wakeup trampoline in first 1MB !NX
>>>> + */
>>>> + if (addr >= PAGE_OFFSET && addr <= (PAGE_OFFSET + (1<<20)))
>>>> + return 1;
>>>> +#endif
>>>
>>> That's pretty ugly. Why not use set_memory_x()/set_memory_nx(), and only for
>>> the
>>> trampoline itself? Does the whole 1MB need to be marked X?
>>
>> The previous code was doing that.
>
> So why not call set_memory_x() in your patch? Mind trying that?
>
OK, there seems to be considerable duplication between
static_protections() and local invocation. Consider PCI BIOS, which is
another X-needed region.
In static_protections() we have:
> /*
> * The BIOS area between 640k and 1Mb needs to be executable for
> * PCI BIOS based config access (CONFIG_PCI_GOBIOS) support.
> */
> #ifdef CONFIG_PCI_BIOS
> if (pcibios_enabled && within(pfn, BIOS_BEGIN >> PAGE_SHIFT, BIOS_END >> PAGE_SHIFT))
> pgprot_val(forbidden) |= _PAGE_NX;
> #endif
... however, in arch/x86/pci/pcbios.c:
> static inline void set_bios_x(void)
> {
> pcibios_enabled = 1;
> set_memory_x(PAGE_OFFSET + BIOS_BEGIN, (BIOS_END - BIOS_BEGIN) >> PAGE_SHIFT);
> if (__supported_pte_mask & _PAGE_NX)
> printk(KERN_INFO "PCI : PCI BIOS aera is rw and x. Use pci=nobios if you want it NX.\n");
> }
This is blatant and insanely ugly code duplication! In particular,
static_protections() is "action at a distance" which has no business
existing at all.
What I want to know is if static_protections() can somehow override
set_bios_x() in this context (in which case it's a serious design
error), or if it is plain redundant -- in the latter case we should
simply use the same technique elsewhere.
-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists