lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 07 Feb 2011 11:01:09 +0000
From:	"Jan Beulich" <>
To:	<>, <>
Cc:	<>, <>,
	<>, <>
Subject: x86: mis-named percpu_xchg_op() after switch to cmpxchg?

Other than its name implies, with the switch to use cmpxchg instead of
xchg (commit 8270137a0d50507a5b40f880db636527045b8466) this
macro is no longer suitable for accessing anything that may be written
by other than the local CPU (i.e. anything but the various this_cpu
accessors). Shouldn't it therefore get renamed to eg this_cpu_xchg_op()?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

Powered by blists - more mailing lists