[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110214110528.GD7140@elte.hu>
Date: Mon, 14 Feb 2011 12:05:28 +0100
From: Ingo Molnar <mingo@...e.hu>
To: Henrik Kretzschmar <henne@...htwindheim.de>
Cc: mingo@...dhat.com, tglx@...utronix.de, hpa@...or.com,
x86@...nel.org, tj@...nel.org, yinghai@...nel.org,
ak@...ux.intel.com, robert.richter@....com,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/6] x86: move ioapic_irq_destination_types
* Henrik Kretzschmar <henne@...htwindheim.de> wrote:
> +++ b/arch/x86/include/asm/apicdef.h
> @@ -426,4 +426,16 @@ struct local_apic {
> #else
> #define BAD_APICID 0xFFFFu
> #endif
> +
> +enum ioapic_irq_destination_types {
> + dest_Fixed = 0,
> + dest_LowestPrio = 1,
> + dest_SMI = 2,
> + dest__reserved_1 = 3,
> + dest_NMI = 4,
> + dest_INIT = 5,
> + dest__reserved_2 = 6,
> + dest_ExtINT = 7
> +};
one very small request, while we are moving it could you please align the value
enumeration vertically? Something like:
enum ioapic_irq_destination_types {
dest_Fixed = 0,
dest_LowestPrio = 1,
dest_SMI = 2,
dest__reserved_1 = 3,
dest_NMI = 4,
dest_INIT = 5,
dest__reserved_2 = 6,
dest_ExtINT = 7
};
... would be much more readable, right?
Thanks,
Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists