[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110214122313.GA10062@albatros>
Date: Mon, 14 Feb 2011 15:23:13 +0300
From: Vasiliy Kulikov <segoon@...nwall.com>
To: Nicolas de Pesloüan
<nicolas.2p.debian@...il.com>
Cc: linux-kernel@...r.kernel.org,
"David S. Miller" <davem@...emloft.net>,
Eric Dumazet <eric.dumazet@...il.com>,
Tom Herbert <therbert@...gle.com>,
Changli Gao <xiaosuo@...il.com>,
Jesse Gross <jesse@...ira.com>, netdev@...r.kernel.org
Subject: Re: [PATCH] core: dev: don't call BUG() on bad input
Hi Nicolas,
On Mon, Feb 14, 2011 at 13:16 +0100, Nicolas de Pesloüan wrote:
> >- BUG_ON(strlen(name)>= sizeof(dev->name));
> >+ if (strnlen(name, sizeof(dev->name))>= sizeof(dev->name)) {
Ehh... Space after ")" is needed :)
> "size_t strnlen(const char *s, size_t maxlen) : The strnlen()
> function returns strlen(s), if that is less than maxlen, or maxlen
> if there is no '\0' character among the first maxlen characters
> pointed to by s."
>
> How can strnlen(name, sizeof(dev->name)) be greater than sizeof(dev->name)?
>
> Shouldn't it be "if (strnlen(name, sizeof(dev->name)) == sizeof(dev->name))" instead?
Not a big deal, but MO it's better to guard from everything that
is not a good input by negating the check. strnlen() < sizeof() is OK,
strnlen() >= sizeof() is bad. Is "==" more preferable for net/ coding style?
--
Vasiliy Kulikov
http://www.openwall.com - bringing security into open computing environments
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists