[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1298060386.15565.25.camel@Joe-Laptop>
Date: Fri, 18 Feb 2011 12:19:46 -0800
From: Joe Perches <joe@...ches.com>
To: Ingo Molnar <mingo@...e.hu>
Cc: mingo@...hat.com, hpa@...or.com, linux-kernel@...r.kernel.org,
jbeulich@...ell.com, tglx@...utronix.de,
linux-tip-commits@...r.kernel.org
Subject: Re: [tip:x86/debug] x86: Combine printk()s in show_regs_common()
On Fri, 2011-02-18 at 21:05 +0100, Ingo Molnar wrote:
> * Joe Perches <joe@...ches.com> wrote:
> > Ingo, why did you choose to apply this patch instead of
> > the alternative one I posted on the same thread?
> Your version:
>
> /* Board Name is optional */
> board = dmi_get_system_info(DMI_BOARD_NAME);
> if (!board)
> board = "";
>
> printk(KERN_CONT "\n");
>
> printk(KERN_DEFAULT "Pid: %d, comm: %.20s %s %s %.*s %s %s%s%s\n",
> current->pid, current->comm, print_tainted(),
> init_utsname()->release,
> (int)strcspn(init_utsname()->version, " "),
> init_utsname()->version,
> vendor, product,
> strlen(board) ? "/" : "",
> board);
>
> The 'board' fiddling and the strlen(board) check complicates things unnecessarily
> and makes the code hard to read. Jan's version was at least simple.
Perhaps you should look at the surrounding code.
It's uses the same style as I chose for "board".
void show_regs_common(void)
{
const char *vendor, *product, *board;
vendor = dmi_get_system_info(DMI_SYS_VENDOR);
if (!vendor)
vendor = "";
product = dmi_get_system_info(DMI_PRODUCT_NAME);
if (!product)
product = "";
...
> Something like this:
>
> /* Board Name is optional */
> board = dmi_get_system_info(DMI_BOARD_NAME);
>
> printk(KERN_CONT "\n");
>
> printk(KERN_DEFAULT "Pid: %d, comm: %.20s %s %s %.*s %s %s %s %s\n",
> current->pid, current->comm, print_tainted(),
> init_utsname()->release,
> (int)strcspn(init_utsname()->version, " "),
> init_utsname()->version,
> vendor, product, board ? : "");
>
> Would be easier to read and gives similarly useful output.
It's a question of using identical output or
merely similar output.
cheers, Joe
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists