[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <alpine.LFD.2.00.1102241510450.2701@localhost6.localdomain6>
Date: Thu, 24 Feb 2011 15:28:02 +0100 (CET)
From: Thomas Gleixner <tglx@...utronix.de>
To: Pratheesh Gangadhar <pratheesh@...com>
cc: davinci-linux-open-source@...ux.davincidsp.com, hjk@...sjkoch.de,
gregkh@...e.de, sshtylyov@...sta.com, arnd@...db.de,
amit.chatterjee@...com, linux-kernel@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH v4 1/2] PRUSS UIO driver support
On Thu, 24 Feb 2011, Pratheesh Gangadhar wrote:
A few nits.
> +static void pruss_cleanup(struct platform_device *dev, struct uio_info *info)
> +{
> + struct uio_info *p = info;
> + int cnt;
> +
> + for (cnt = 0; cnt < MAX_PRUSS_EVT; cnt++, p++) {
> + uio_unregister_device(p);
> + kfree(p->name);
> + }
> + iounmap(prussio_vaddr);
> + if (ddr_vaddr)
> + dma_free_coherent(&dev->dev, info->mem[2].size,
> + info->mem[2].internal_addr, info->mem[2].addr);
That is easier to read with curly braces even if they are strictly not
necessary
if (ddr_vaddr) {
dma_free_coherent(&dev->dev, info->mem[2].size,
info->mem[2].internal_addr, info->mem[2].addr);
}
> + kfree(info);
> + clk_put(pruss_clk);
> +}
> + len = resource_size(regs_ddr);
> + ddr_vaddr =
> + dma_alloc_coherent(&dev->dev, len, &ddr_paddr, GFP_KERNEL | GFP_DMA);
That wants to be:
ddr_vaddr = dma_alloc_coherent(&dev->dev, len, &ddr_paddr,
GFP_KERNEL | GFP_DMA);
Otherwise this looks very clean and readable now and I can't spot any
technical problems with it anymore.
Please fixup the nits and feel free to add
Reviewed-by: Thomas Gleixner <tglx@...utronix.de>
Thanks for following up on all this!
tglx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists