[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <6E21E5352C11B742B20C142EB499E048015780@TK5EX14MBXC128.redmond.corp.microsoft.com>
Date: Sat, 26 Feb 2011 17:13:31 +0000
From: KY Srinivasan <kys@...rosoft.com>
To: Dan Carpenter <error27@...il.com>
CC: "gregkh@...e.de" <gregkh@...e.de>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"devel@...uxdriverproject.org" <devel@...uxdriverproject.org>,
"virtualization@...ts.osdl.org" <virtualization@...ts.osdl.org>
Subject: RE: [PATCH 3/6] Staging: hv: Cleanup hyperv_device variable names
> -----Original Message-----
> From: Dan Carpenter [mailto:error27@...il.com]
> Sent: Friday, February 25, 2011 10:33 PM
> To: KY Srinivasan
> Cc: gregkh@...e.de; linux-kernel@...r.kernel.org;
> devel@...uxdriverproject.org; virtualization@...ts.osdl.org
> Subject: Re: [PATCH 3/6] Staging: hv: Cleanup hyperv_device variable names
>
> On Fri, Feb 25, 2011 at 06:06:32PM -0800, K. Y. Srinivasan wrote:
> > Cleanup the names of variables that refer to the
> > hyperv_device abstraction.
> >
>
> I have a script I run on rename patches. For this patch the
> command would be:
>
> rename_rev.pl -nc -e 's/device_ctx/device_obj/g' -e 's/\bdev_ctx/dev/g'
>
> It show one variable was missed in storvsc_probe().
>
> > memset(host_device_ctx, 0, sizeof(struct host_device_context));
> >
> > host_device_ctx->port = host->host_no;
> > - host_device_ctx->device_ctx = device_obj;
> > + host_device_ctx->device_obj = device_obj;
> >
> > host_device_ctx->request_pool =
> > kmem_cache_create(dev_name(&device_obj-
> >device),
> > @@ -271,7 +271,7 @@ static int storvsc_probe(struct device *device)
> > return -1;
> > }
> >
> > - /* host_device_ctx->port = device_info.PortNumber; */
> > + /* host_hyperv_dev->port = device_info.PortNumber; */
> > host_device_ctx->path = device_info.path_id;
> > host_device_ctx->target = device_info.target_id;
> >
>
> All the other host_device_ctx variables were renamed to host_device_obj.
host_device_ctx is a scsi abstraction built on top of the hyperv_device
abstraction. My goal was not to change the names of higher level scsi
abstractions.
Regards,
K. Y
>
> regards,
> dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists