[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110301205234.GA5605@merkur.ravnborg.org>
Date: Tue, 1 Mar 2011 21:52:34 +0100
From: Sam Ravnborg <sam@...nborg.org>
To: Chris Metcalf <cmetcalf@...era.com>
Cc: linux-kernel@...r.kernel.org
Subject: Re: [PATCH] arch/tile: catch up with section naming convention in
2.6.35
Hi Chris.
A few improvement proposals.
Sam
> index 90e7c44..fc49b62 100644
> --- a/arch/tile/kernel/head_32.S
> +++ b/arch/tile/kernel/head_32.S
> @@ -133,7 +133,7 @@ ENTRY(_start)
> }
> ENDPROC(_start)
>
> -.section ".bss.page_aligned","w"
> +.section ".bss..page_aligned","w"
Here you could use
__PAGE_ALIGNED_BSS
> .align PAGE_SIZE
> ENTRY(empty_zero_page)
> .fill PAGE_SIZE,1,0
> @@ -148,7 +148,7 @@ ENTRY(empty_zero_page)
> .word (\bits1) | (HV_CPA_TO_PFN(\cpa) << HV_PTE_INDEX_PFN)
> .endm
>
> -.section ".data.page_aligned","wa"
> +.section ".data..page_aligned","wa"
and here you could use
__PAGE_ALIGNED_DATA
> /* This page is remapped on startup to be hash-for-home. */
> int atomic_locks[PAGE_SIZE / sizeof(int) /* Only ATOMIC_HASH_SIZE is used */]
> - __attribute__((aligned(PAGE_SIZE), section(".bss.page_aligned")));
> + __attribute__((aligned(PAGE_SIZE), section(".bss..page_aligned")));
__page_aligned_bss
Sam
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists