lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 3 Mar 2011 10:18:27 +0100
From:	Johannes Weiner <hannes@...xchg.org>
To:	Andi Kleen <andi@...stfloor.org>
Cc:	akpm@...ux-foundation.org, aarcange@...hat.com, linux-mm@...ck.org,
	linux-kernel@...r.kernel.org, Andi Kleen <ak@...ux.intel.com>
Subject: Re: [PATCH 8/8] Add VM counters for transparent hugepages

On Wed, Mar 02, 2011 at 04:45:28PM -0800, Andi Kleen wrote:
> --- a/include/linux/vmstat.h
> +++ b/include/linux/vmstat.h
> @@ -58,6 +58,13 @@ enum vm_event_item { PGPGIN, PGPGOUT, PSWPIN, PSWPOUT,
>  		UNEVICTABLE_PGCLEARED,	/* on COW, page truncate */
>  		UNEVICTABLE_PGSTRANDED,	/* unable to isolate on unlock */
>  		UNEVICTABLE_MLOCKFREED,
> +#ifdef CONFIG_TRANSPARENT_HUGEPAGE
> +	        THP_FAULT_ALLOC,
> +		THP_COLLAPSE_ALLOC,	
> +		THP_FAULT_FALLBACK,	

Wouldn't this better be named THP_FAULT_ALLOC_FAIL?  After all, it
counts allocation failures, not what results from them.

Secondly, the order does not match the strings, it will report the
THP_COLLAPSE_ALLOC item as "thp_fault_fallback" and vice versa.

There are also odd spaces after the lines defining THP_COLLAPSE_ALLOC
and this one.

> +		THP_COLLAPSE_ALLOC_FAILED,
> +		THP_SPLIT,
> +#endif
>  		NR_VM_EVENT_ITEMS
>  };

> diff --git a/mm/vmstat.c b/mm/vmstat.c
> index 2b461ed..a23f2d2 100644
> --- a/mm/vmstat.c
> +++ b/mm/vmstat.c
> @@ -946,6 +946,14 @@ static const char * const vmstat_text[] = {
>  	"unevictable_pgs_stranded",
>  	"unevictable_pgs_mlockfreed",
>  #endif
> +
> +#ifdef CONFIG_TRANSPARENT_HUGEPAGE
> +	"thp_fault_alloc",
> +	"thp_fault_fallback",
> +	"thp_collapse_alloc",
> +	"thp_collapse_alloc_failure",

Can you make this "_failed" instead, to match the enum symbol?  Andrea
wasn't sure which was better, "failure" or "failed".  Right now, we
have two instances of "fail" and two instances of "failed" in
/proc/vmstat, it's probably best not to introduce a third one.

Thanks.

	Hannes
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ