lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:	Tue, 15 Mar 2011 15:18:37 +0100
From:	Daniel Kiper <dkiper@...-space.pl>
To:	Stefano Stabellini <stefano.stabellini@...citrix.com>
Cc:	Daniel Kiper <dkiper@...-space.pl>,
	Ian Campbell <Ian.Campbell@...citrix.com>,
	"akpm@...ux-foundation.org" <akpm@...ux-foundation.org>,
	"andi.kleen@...el.com" <andi.kleen@...el.com>,
	"haicheng.li@...ux.intel.com" <haicheng.li@...ux.intel.com>,
	"fengguang.wu@...el.com" <fengguang.wu@...el.com>,
	"jeremy@...p.org" <jeremy@...p.org>,
	"konrad.wilk@...cle.com" <konrad.wilk@...cle.com>,
	Dan Magenheimer <dan.magenheimer@...cle.com>,
	"v.tolstov@...fip.ru" <v.tolstov@...fip.ru>,
	"pasik@....fi" <pasik@....fi>,
	"dave@...ux.vnet.ibm.com" <dave@...ux.vnet.ibm.com>,
	"wdauchy@...il.com" <wdauchy@...il.com>,
	"rientjes@...gle.com" <rientjes@...gle.com>,
	"xen-devel@...ts.xensource.com" <xen-devel@...ts.xensource.com>,
	"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
	"linux-mm@...ck.org" <linux-mm@...ck.org>
Subject: Re: [PATCH R4 2/7] xen/balloon: HVM mode support

On Wed, Mar 09, 2011 at 01:58:30PM +0000, Stefano Stabellini wrote:
> On Tue, 8 Mar 2011, Daniel Kiper wrote:
> > HVM mode support.
>
> I have already a patch in linux-next to do this, please give a look at
> "xen: make the ballon driver work for hvm domains":
>
> git://xenbits.xen.org/people/sstabellini/linux-pvhvm.git linux-next

OK, I will remove this patch from memory hotplug patchset, however:

@@ -232,7 +232,7 @@ static int increase_reservation(unsigned long nr_pages)
 		set_phys_to_machine(pfn, frame_list[i]);
 
 		/* Link back into the page tables if not highmem. */
-		if (pfn < max_low_pfn) {
+		if (!xen_hvm_domain() && pfn < max_low_pfn) {

Why do not write it as:

if (xen_pv_domain() && !PageHighMem(page)) ...

For me it is simpler to read (xen_pv_domain()) and make it similar
to relevant part in decrease_reservation() (!PageHighMem(page)).

@@ -280,7 +280,7 @@ static int decrease_reservation(unsigned long nr_pages)
 
 		scrub_page(page);
 
-		if (!PageHighMem(page)) {
+		if (!xen_hvm_domain() && !PageHighMem(page)) {

As above.

@@ -392,15 +392,19 @@ static struct notifier_block xenstore_notifier;
 
 static int __init balloon_init(void)
 {
-	unsigned long pfn, extra_pfn_end;
+ 	unsigned long pfn, nr_pages, extra_pfn_end;
 	struct page *page;
 
-	if (!xen_pv_domain())
+	if (!xen_domain())
 		return -ENODEV;
 
 	pr_info("xen_balloon: Initialising balloon driver.\n");
 
-	balloon_stats.current_pages = min(xen_start_info->nr_pages, max_pfn);
+ 	if (xen_pv_domain())
+ 		nr_pages = xen_start_info->nr_pages;
+ 	else
+ 		nr_pages = max_pfn;
+ 	balloon_stats.current_pages = min(nr_pages, max_pfn);

It could be simplified:

balloon_stats.current_pages = xen_pv_domain() ? min(xen_start_info->nr_pages, max_pfn) : max_pfn;

Daniel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ