[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20110317145730.8e650401.akpm@linux-foundation.org>
Date: Thu, 17 Mar 2011 14:57:30 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Dave Jones <davej@...hat.com>
Cc: Steven Rostedt <rostedt@...dmis.org>,
Linux Kernel <linux-kernel@...r.kernel.org>,
Linus Torvalds <torvalds@...ux-foundation.org>
Subject: Re: make checkpatch warn about memset with swapped arguments.
On Thu, 17 Mar 2011 17:32:52 -0400
Dave Jones <davej@...hat.com> wrote:
> On Thu, Mar 17, 2011 at 02:11:08PM -0700, Andrew Morton wrote:
>
> > Dave's patch is tested (I assume), so it wins ;)
>
> indeed, it's the one I've been using for.. ages.
>
> > Maybe it's just me, but I think it would be better to use bzero() for
> > this operation - it's more readable and it can't be screwed up. Then
> > checkpatch checks for memset(xxx, 0, xxx) and for memset(xxx, xxx, 0)
> > and says "hey, use bzero".
>
> god yes. I don't know why it fell out of favor in userspace[*], but we
> don't have to follow suit in the kernel. I thought we actually had
> a generic bzero, but it seems not from a quick grep. I'll hack something up.
>
> it only needs to be a #define bzero(x,y) memset (x, 0, y);
>
> where should it live, linux/kernel.h ?
Thou shalt not implement in CPP that which can be implemented in C.
and..
Thou shalt not implement in C that which is already a gcc builtin :)
I'm OK with switching from memset to bzero as the preferred way of
clearing memory (shorter, clearer, not susceptible to the arg reversal
bug). Is Linus?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists