lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 4 May 2011 11:05:09 +0200
From:	Tejun Heo <htejun@...il.com>
To:	shaohua.li@...el.com
Cc:	linux-kernel@...r.kernel.org, linux-ide@...r.kernel.org,
	jaxboe@...ionio.com, jgarzik@...ox.com, hch@...radead.org,
	djwong@...ibm.com
Subject: Re: [patch v2 1/3] block: add a non-queueable flush flag

Hello,

On Wed, May 04, 2011 at 04:17:26PM +0800, shaohua.li@...el.com wrote:
> flush request isn't queueable in some drives. Add a flag to let driver
> notify block layer about this. We can optimize flush performance with the
> knowledge.
> 
> Signed-off-by: Shaohua Li <shaohua.li@...el.com>
> ---
>  include/linux/blkdev.h |   11 +++++++++++
>  1 file changed, 11 insertions(+)
> 
> Index: linux/include/linux/blkdev.h
> ===================================================================
> --- linux.orig/include/linux/blkdev.h	2011-05-04 14:23:42.000000000 +0800
> +++ linux/include/linux/blkdev.h	2011-05-04 14:24:40.000000000 +0800
> @@ -364,6 +364,7 @@ struct request_queue
>  	 * for flush operations
>  	 */
>  	unsigned int		flush_flags;
> +	unsigned int		flush_not_queueable:1;
>  	unsigned int		flush_pending_idx:1;
>  	unsigned int		flush_running_idx:1;
>  	unsigned long		flush_pending_since;
> @@ -549,6 +550,16 @@ static inline void blk_clear_queue_full(
>  		queue_flag_clear(QUEUE_FLAG_ASYNCFULL, q);
>  }
>  
> +static inline void blk_set_queue_flush_queueable(struct request_queue *q,
> +		bool queueable)
> +{
> +	q->flush_not_queueable = !queueable;
> +}
> +
> +static inline bool blk_queue_flush_queueable(struct request_queue *q)
> +{
> +	return !q->flush_not_queueable;
> +}

In the block layer, these setters live in block/blk-settings.c and
usually don't have _set in their names.

Also, negation in the interface is slightly bothering but I can't
think of better name meaning !queueable either, so unless someone can
come up with better name, it should do, I think.

Thank you.

-- 
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ