[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20110510070646.GB13847@infradead.org>
Date: Tue, 10 May 2011 03:06:46 -0400
From: Christoph Hellwig <hch@...radead.org>
To: "K. Y. Srinivasan" <kys@...rosoft.com>
Cc: gregkh@...e.de, linux-kernel@...r.kernel.org,
devel@...uxdriverproject.org, virtualization@...ts.osdl.org,
Haiyang Zhang <haiyangz@...rosoft.com>,
Abhishek Kane <v-abkane@...rosoft.com>,
Hank Janssen <hjanssen@...rosoft.com>
Subject: Re: [PATCH 115/206] Staging: hv: Use completion abstraction in
struct netvsc_device
> - net_device->wait_condition = 0;
> ret = vmbus_sendpacket(device->channel, init_packet,
> sizeof(struct nvsp_message),
> (unsigned long)init_packet,
> @@ -272,10 +272,8 @@ static int netvsc_init_recv_buf(struct hv_device *device)
> goto cleanup;
> }
>
> - wait_event_timeout(net_device->channel_init_wait,
> - net_device->wait_condition,
> - msecs_to_jiffies(1000));
> - BUG_ON(net_device->wait_condition == 0);
> + t = wait_for_completion_timeout(&net_device->channel_init_wait, HZ);
> + BUG_ON(t == 0);
I don't think you want a BUG_ON here, but rather fail the
initialization.
Also I think you really should add synchronous versions of
vmbus_sendpacket*, to the vmbus core so that all the synchronous waiting
can be consolidated into a few helpers instead of needing to opencode
it everywhere.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists